We encountered an error while storing the credit card. | Coursera Community
Coursera Header
Solved

We encountered an error while storing the credit card.

  • 25 January 2019
  • 9 replies
  • 521 views

Badge +1
I've tried two different credit cards and two different browsers and keep getting the error, "We encountered an error while storing the credit card." Is there a known issue that causes this?
icon

Best answer by Laura 25 January 2019, 19:12

Hi @Mark L. I'm sorry, that sounds frustrating! I'm not aware of a known issue that would be causing this. Have you visited the Help Center yet? Here's an article that contains a section about getting errors when trying to pay: Solve problems with payments.
View original

9 replies

Userlevel 7
Badge +13
Hi @Mark L. I'm sorry, that sounds frustrating! I'm not aware of a known issue that would be causing this. Have you visited the Help Center yet? Here's an article that contains a section about getting errors when trying to pay: Solve problems with payments.
Badge +1
Thank you Laura for the response. Yes, I tried all of the suggestions on that page before I posted.
Badge +1
Thanks again Laura. It has now went through.
Userlevel 7
Badge +13
Thank you for letting us know that it went through successfully! I'm sorry that it took you several attempts. Thank you for persevering. 🙂
Badge
Hi, I've the same problem when I try to use my card.
I've read all the article contained in the help center too.
What can I do?
Many thanks in advance.
Best regards
Userlevel 7
Badge +13
Hi @ambra. You can click the "Contact us" button at the end of the Solve problems with payments article to get in touch with a member of our support team.
Badge
Hi @Laura,

Many thanks for your help.

Best regards,
Ambra
I have a same problem. I have to use a specific credit card because I'm an enterprise user, and the card I registered has been rejected.

And "Contact us" button doesn't work in my environment. It takes me to "Oops!" page.

Does anyone have solved the problem?
Userlevel 7
Badge +13
Hi @Takuya. Sorry to hear you're having this issue. Let's see if we can get the "Contact us" button to work. Please try the following steps:

1) Use Chrome as a web browser if you're not already doing so.

2) Test the link in Chrome's Incognito mode (File > New Incognito Window). If the link works in Incognito mode, then please clear your cache.

If you try this and continue to get the same error message, please let me know. Thank you!

Reply