"Contact us" - Site not accessible | Coursera Community
Coursera Header
Solved

"Contact us" - Site not accessible

  • 7 August 2019
  • 4 replies
  • 108 views

Badge +1
I am trying to solve a problem via mail or live chat. However, when I am trying to click on "Contact us" (on any page), I always get this error message:
[h4]"We can't seem to find the page you requested. You may have mistyped the address or the page may have moved."[/h4]
icon

Best answer by Laura 7 August 2019, 23:24

Thank you for these detailed ideas, @Halla!

It's possible one of these options will work for you, @jo_ku, but unfortunately there is a strange bug causing this issue. You can contact the support team here.
View original

4 replies

Hi @jo_ku I am sorry you are having trouble. I just tried and it is working for me, which does not necessarily mean that is is for everyone. Let me suggest a couple of troubleshooting tips and if you still can't get through I'll see if we can get some help on this.
My first suggestion is that you clear your browser's cache and cookies, sometimes that will clear problems with Coursera by itself. Then go to the main help center page. Make sure you are logged in to the HC, this is different than being logged in to Coursera proper. Look for the login button in the upper right of your screen. Once you are logged in, you may have to read an article or two about your issue. If they don solve the problem it will eventually give an option of contact. Select that, you may have to answer more questions about why you want to contact the HC but you should eventually get the option of either email or chat and be good to go. All of the above assumes that you are NOT in Russia or China. If you are, that is a whole new set of problems.
Try these things and let me know what, if any work, and if none do we'll find something else to try. Good luck with it and do, please, let me know if this is successful or not
Userlevel 7
Thank you for these detailed ideas, @Halla!

It's possible one of these options will work for you, @jo_ku, but unfortunately there is a strange bug causing this issue. You can contact the support team here.
Hi @Laura I was going to ping you if my tips didn't help, so I am glad you're here. Thank you for the additional support.
Badge +1
Many thanks to both of you for your quick response. I have reached the live chat with your help!

Reply